Publié par Julien L., le Mercredi 09 Mars 2011

Firefox et Chrome risquent de crasher à cause d'anciens pilotes graphiques

Les navigateurs web commencent progressivement à miser sur la puissance des cartes graphiques pour afficher certains graphismes. Or, il s'avère que l'accélération matérielle peut causer quelques problèmes avec des pilotes trop anciens. Des incidents ont été relevés avec Firefox et Chrome, et les éditeurs invitent les utilisateurs à utiliser des pilotes plus récents.

Pour alléger la charge du processeur et mettre à profit la puissance de la carte graphique, les principaux éditeurs de navigateurs web ont commencé à intégrer l'accélération matérielle. Avec Firefox 4, dont la douzième version beta a été publiée à la fin du mois de février, certaines opérations sont ainsi traitées par la carte graphique, avec Direct3D pour Windows (XP, Vista, 7) et OpenGL pour Mac OS X.

L'arrivée de l'accélération matérielle dans Firefox 4 a néanmoins fait apparaître un problème de stabilité inattendu. Un développeur logiciel chez Mozilla, Benoit Jacob, a constaté dans le suivi des incidents du navigateur un problème suite à l'activation par défaut de cette fonctionnalité à partir de la septième version beta, publiée en septembre 2010.

"Nous avons réagi de manière sélective en désactivant cette nouvelle fonctionnalité sur les pilotes graphiques buggés, en nous basant sur la grande quantité d'informations collectée par nos beta testeurs. Bien entendu, Firefox reste entièrement fonctionnel ; seule cette nouvelle fonctionnalité a été désactivée" a commenté Benoit Jacob. Une longue liste de pilotes graphiques a été publiée, concernant à la fois Windows, Mac et Linux (plate-forme X11).

Un utilisateur confronté à ce problème peut le résoudre assez simplement. Il lui suffit de télécharger et installer des pilotes graphiques plus récents, afin de réduire le risque de crash de Firefox 4 à cause de l'accélération matérielle. Ce souci ne se limite d'ailleurs pas au seul navigateur web de Mozilla. Le navigateur de Google, Chrome, supporte aussi l'accélération matérielle depuis la version 7 et est confronté à la même difficulté.

Publié par Julien L., le 9 Mars 2011 à 11h36
 
23
Commentaires à propos de «Firefox et Chrome risquent de crasher à cause d'anciens pilotes graphiques»
Inscrit le 30/04/2005
12571 messages publiés
On risque la sortie de route à des vitesses élevées
Inscrit le 02/12/2010
106 messages publiés
Je veux pas faire mon troll, mais mettre à jour son navigateur sans mettre à jour le reste, c'est pas un peu bête ?
Inscrit le 05/11/2008
421 messages publiés
Eastchild, le 09/03/2011 - 11:39

Je veux pas faire mon troll, mais mettre à jour son navigateur sans mettre à jour le reste, c'est pas un peu bête ?


Bah pas forcements, Je vais peut être alimenté un troll linux (au quel cas je répondrais plus) mais sous windows tout se met a jour manuellement , Firefox et chrome (les autres je sais pas) proposes les jours quand elles sont dispo. Windows lui-même se vérifie (moi ca me soul donc jle fait pas mais passons) mais les pilotes en général ne prévienne pas en cas de MaJ et contrairement au logiciel choisis par l'user , les pilotes sont inconnu du plus grand nombre ...

donc j'ai envie de répondre que c'est pas totalement bêtes , c'est principalement due a l'ignorance (enfin c'est mon avis)
Inscrit le 09/11/2009
311 messages publiés
HellFuret, le 09/03/2011 - 11:47
c'est pas totalement bête , c'est principalement du a l'ignorance


Inscrit le 11/03/2009
3532 messages publiés
si c est juste un pb de drivers à mettre à jour c est pas bien méchant , par contre quelqu un a une idée de la carte graphique minima à avoir , genre ma vieille nvidia 6800 gt ça vas aller ?? quelqu un à des precisions ?
Inscrit le 31/12/2004
951 messages publiés
speed, le 09/03/2011 - 11:47

si c est juste un pb de drivers à mettre à jour c est pas bien méchant , par contre quelqu un a une idée de la carte graphique minima à avoir , genre ma vieille nvidia 6800 gt ça vas aller ?? quelqu un à des precisions ?


Et dire que mon BI-Athlon MP tourne encore avec une FX 5200
[message édité par Breizh 29 le 10/04/2011 à 00:48 ]
Inscrit le 17/03/2006
767 messages publiés
@Eastchild : Sauf quand la carte graphique devient trop vieille et qu'elle ne supporte plus les nouveaux drivers qui de plus en plus sont des drivers "génériques" destinés à l'ensemble des cartes de la game.
Cela m'est arrivé une paire de fois sur mes ordis.
Inscrit le 11/03/2009
3532 messages publiés
HellFuret, le 09/03/2011 - 11:47
Eastchild, le 09/03/2011 - 11:39

Je veux pas faire mon troll, mais mettre à jour son navigateur sans mettre à jour le reste, c'est pas un peu bête ?


Bah pas forcements, Je vais peut être alimenté un troll linux (au quel cas je répondrais plus) mais sous windows tout se met a jour manuellement , Firefox et chrome (les autres je sais pas) proposes les jours quand elles sont dispo. Windows lui-même se vérifie (moi ca me soul donc jle fait pas mais passons) mais les pilotes en général ne prévienne pas en cas de MaJ et contrairement au logiciel choisis par l'user , les pilotes sont inconnu du plus grand nombre ...

donc j'ai envie de répondre que c'est pas totalement bêtes , c'est principalement due a l'ignorance (enfin c'est mon avis)



à l epoque ou j utilisai windows j allais direct dans msconfig virer les trucs nvidia qui envahissent le systray , mais je pense qu en laissant tout activé par défaut il doit bien y avoir un truc qui scanne les updates et propose de les installer , à vrai dire j en sais rien mais ça me paraitrai logique .
Inscrit le 02/04/2009
748 messages publiés
ça me rappelle que Mozilla a l'intention de désactiver OpenGL par defaut sur Linux; de qui se moque t'on? Mozilla vendus a Windows et OSX?
Inscrit le 09/11/2009
311 messages publiés
zanzibar, le 09/03/2011 - 12:34
ça me rappelle que Mozilla a l'intention de désactiver OpenGL par defaut sur Linux; de qui se moque t'on? Mozilla vendus a Windows et OSX?


Non, le problème avec Linux vient du fait que beaucoup des drivers vidéo y sont instables et/ou mal supportés par Xorg (si j'ai bien compris, hein, je ne suis pas un expert).

Ceci dit il ne s'agit que d'une désactivation par défaut, tu peux toujours réactiver l'accélération graphique et juger par toi-même. :-)
Inscrit le 11/09/2009
26 messages publiés
Gnuzer, le 09/03/2011 - 11:58
HellFuret, le 09/03/2011 - 11:47
c'est pas totalement bête , c'est principalement du a l'ignorance


La bêtise est une conséquence possible de l'ignorance mais l'ignorance en soit n'est pas de la bêtise

Tout ce que m'inspire cet article, c'est qu'il faudrait que je vérifie ou en sont mes pilotes. Ceci dit, vu la vétuste de mon pc, ça m'étonnerais qu'il y en ait de nouveaux.
Inscrit le 04/09/2002
2509 messages publiés
avec une vieille carte graphique (c'est mon cas: geforce 4 ti 4200, mais une carte excellente!), il reste délicat de mettre à jour les pilotes: on peut vite se retrouver avec des bugs en pagaille.
Inscrit le 26/04/2005
367 messages publiés
HellFuret, le 09/03/2011 - 11:47
Eastchild, le 09/03/2011 - 11:39

Je veux pas faire mon troll, mais mettre à jour son navigateur sans mettre à jour le reste, c'est pas un peu bête ?


Bah pas forcements, Je vais peut être alimenté un troll linux (au quel cas je répondrais plus) mais sous windows tout se met a jour manuellement , Firefox et chrome (les autres je sais pas) proposes les jours quand elles sont dispo. Windows lui-même se vérifie (moi ca me soul donc jle fait pas mais passons) mais les pilotes en général ne prévienne pas en cas de MaJ et contrairement au logiciel choisis par l'user , les pilotes sont inconnu du plus grand nombre ...

donc j'ai envie de répondre que c'est pas totalement bêtes , c'est principalement due a l'ignorance (enfin c'est mon avis)



à l epoque ou j utilisai windows j allais direct dans msconfig virer les trucs nvidia qui envahissent le systray , mais je pense qu en laissant tout activé par défaut il doit bien y avoir un truc qui scanne les updates et propose de les installer , à vrai dire j en sais rien mais ça me paraitrai logique .

C'est pas toujours possible de mettre à jour. Sur le dernier portable sous windows, ATI dit que c'est une version portable, donc faut voir avec l'assembleur. Mais l'assembleur (Fujitsu-siemens) n'a jamais fourni de mise à jour. Et essayer avec une version normale des nouveaux pilotes ne marche pas.

Sinon c'est sûr, sous linux y'a pas ce problème.
Inscrit le 30/04/2010
629 messages publiés
SkeROy, le 09/03/2011 - 15:47
HellFuret, le 09/03/2011 - 11:47
Eastchild, le 09/03/2011 - 11:39

Je veux pas faire mon troll, mais mettre à jour son navigateur sans mettre à jour le reste, c'est pas un peu bête ?


Bah pas forcements, Je vais peut être alimenté un troll linux (au quel cas je répondrais plus) mais sous windows tout se met a jour manuellement , Firefox et chrome (les autres je sais pas) proposes les jours quand elles sont dispo. Windows lui-même se vérifie (moi ca me soul donc jle fait pas mais passons) mais les pilotes en général ne prévienne pas en cas de MaJ et contrairement au logiciel choisis par l'user , les pilotes sont inconnu du plus grand nombre ...

donc j'ai envie de répondre que c'est pas totalement bêtes , c'est principalement due a l'ignorance (enfin c'est mon avis)



à l epoque ou j utilisai windows j allais direct dans msconfig virer les trucs nvidia qui envahissent le systray , mais je pense qu en laissant tout activé par défaut il doit bien y avoir un truc qui scanne les updates et propose de les installer , à vrai dire j en sais rien mais ça me paraitrai logique .

C'est pas toujours possible de mettre à jour. Sur le dernier portable sous windows, ATI dit que c'est une version portable, donc faut voir avec l'assembleur. Mais l'assembleur (Fujitsu-siemens) n'a jamais fourni de mise à jour. Et essayer avec une version normale des nouveaux pilotes ne marche pas.

Sinon c'est sûr, sous linux y'a pas ce problème.


Bah c'est normal, pour ton laptop il faut prendre les drivers catalyst mobility sur le site officiel d'ati/amd , pas besoin d'aller sur le site de l'assembleur..
[message édité par erak le 09/03/2011 à 16:12 ]
Inscrit le 26/04/2005
367 messages publiés
Je vais réessayer, mais je suis sûr que c'est ce que j'avais fait. a+
Inscrit le 13/03/2003
1381 messages publiés
speed, le 09/03/2011 - 11:47
si c est juste un pb de drivers à mettre à jour c est pas bien méchant , par contre quelqu un a une idée de la carte graphique minima à avoir , genre ma vieille nvidia 6800 gt ça vas aller ?? quelqu un à des precisions ?

pas bien méchant, c'est vite dit...
pour ceux qui on une vraie CG, ca devrait pas être le bout du monde...
et a la rigueur on peut faire confiance a ati et Nvidia pour mettre a jour leur pilotes "legacy" exceptionnellement...

par contre les cartes intégrées, surtout dans les portables, chez des constructeurs qui n'autorisent pas les pilotes génériques...
ca va être la joie...

faut espérer qu'as terme, les navigateurs finissent par carrément reconnaître les drivers auxquels ils on affaire et activent ou pas l'accélération matérielle en conséquence...
[message édité par Blastm le 09/03/2011 à 16:43 ]
Inscrit le 30/04/2005
12571 messages publiés
Aucun souci de compatibilité avec les pilotes récents pour les cartes intégrées (version 10 de Chrome et FF 3.6.14), sauf que le bénéfice est dérisoire sur ce type de matériel.
Inscrit le 17/02/2010
1205 messages publiés
Une longue liste de pilotes graphiques a été publiée, concernant à la fois Windows, Mac et Linux (plate-forme X11).


plate-forme X11, cela ne veut rien dire !! MDR. Veuillez reformuler svp.

Soit dit en passant Gnu/Linux s'en sort vraiment bien, face a la concurrence: "XRender is used via Cairo, and is not subject to any blacklisting "
[message édité par H4rlocK le 09/03/2011 à 20:14 ]
Inscrit le 21/02/2006
4168 messages publiés
speed, le 09/03/2011 - 11:47
si c est juste un pb de drivers à mettre à jour c est pas bien méchant , par contre quelqu un a une idée de la carte graphique minima à avoir , genre ma vieille nvidia 6800 gt ça vas aller ?? quelqu un à des precisions ?


l'accélération matériel n'est apparut que depuis les geforce 8xxx (8800 8600 etc)
Inscrit le 06/10/2009
487 messages publiés
stacato, le 09/03/2011 - 12:31
A condition de trouver des drivers récents... parce qu'un des moyens utilisés par les fabriquants de matériel pour forcer les gens à changer, c'est justement de ne pas mettre à jour les drivers.


Effectivement comme certain Pc portable utilisant des drivers Nvidia spécifique et n'étant jamais mise à jours par la boite (dells,toshiba etc).
Après heureusement on peut trouver des "hack" de drivers pour rendre les nouveaux compatible à la version special de notre pc portable mais bon ca c'est pas évident pour tout le monde car ca demande quelques manip :/
Inscrit le 23/03/2010
193 messages publiés
Bah, bah, bah !!!! ... Mon petit Breithz 29 ça c'est marrant !... C'est une très bonne carte ta FX 5200, la preuve, j'en ai fait tourner une hier (si, si !) sous 7 SP1 ..avec Firefox 4 beta. Comme quoi les vieux matos ont la vie dure.
Inscrit le 22/03/2006
649 messages publiés
Devant la lenteur de firefox il y a quelques mois, je suis passé à Opéra et depuis tout marche bien...
Inscrit le 11/03/2011
1 messages publiés
En plus, du côté de l'accélération matérielle, Chrome et Firefox semblent clairement à la traine par rapport à IE9 et Opera apparemment: http://blogs.msdn.co...me-vitesse.aspx
[message édité par operateur le 11/03/2011 à 12:02 ]
Répondre

Tous les champs doivent être remplis.

OU

Tous les champs doivent être remplis.

FORUMS DE NUMERAMA
Poser une question / Créer un sujet
vous pouvez aussi répondre ;-)
Numerama sur les réseaux sociaux
Mars 2011
 
Lu Ma Me Je Ve Sa Di
28 1 2 3 4 5 6
7 8 9 10 11 12 13
14 15 16 17 18 19 20
21 22 23 24 25 26 27
28 29 30 31 1 2 3
4 5 6 7 8 9 10